Areas of Interest, as counted by my cat

Month: April 2009

Ubuntu Diary – Day 3

I plugged my camera into a spare USB port, and waited. It just works… Ubuntu recognised the attached storage and prompted me for an application. I chose F-Spot Photo Manager because it seemed like the right thing to do, and successfully copied the images to the filesystem. That is a complete success, in my book, except for the following issues:

  • I'd created a folder ~/pictures/camera but for some reason I could not copy the images from the camera to that location. I ended up putting them in ~/pictures instead, and then moving them manually later.
  • By default Ubuntu apparently created a directory called ~/Photos for me but I swear I don't remember seeing it before. Did F-Spot do this, or am I just blind? [Update: The directory was created last night, so I expect F-Spot did it, or perhaps Ubuntu did after it recognised the camera.]
  • I couldn't figure out how to move the images from the camera (thus relieving me of the need to delete them from the camera in a separate operation).

(The camera is a FujiFilm FinePix 602z. The laptop is a Sony Vaio FE790G.)

Ubuntu Diary – Day 2

I have Windows XP running in a Virtual Box 2.2 virtual machine now. I gave it 950 MB of RAM, very smooth now that the VirutalBox Machine Additions are installed. Seemless Mode is mindblowing the first time you see it – that's where you have Windows XP applictions floating in the Ubuntu desktop with no container window. For now I have it set back to "normal" mode. Both it and the host Ubuntu OS seem to be getting their IP addresses via DHCP, I never had to specify an IP although I had some all ready to assign to them. I suspect that static IPs will be required at some point…

This blog website looked a little weird in Ubuntu until I installed the Microsoft Core TrueType fonts for Linux. I should do something about that at some point, I guess. On the other hand, I'm not ashamed that my heritage is Windows, so for now, it can stay the way it is.

The Flash plugin isn't installed by default but it was very straightforward to install. I just followed the "Click here to install" link and it worked. Quicktime was almost as easy – it seems that there is a plugin registered to Quicktime but it needs some codecs, but again, it prompts you for the installation and after a few minutes, it just works. Great.

Now, I have all my Windows documents, etc, backed up on to our NAS drive, and although Ubuntu found the network resource and let me browse it (it helps to use the same username/password for every device on the LAN), it seems that many Ubuntu/Gnome applications won't load files from network drives. The "Open File" dialog will allow you to go there and select a file, but it doesn't seem to take effect. Two examples: Restoring my Firefox bookmarks from a .JSON  backup – I needed to copy the .json file into my home directory on the local filesystem before it worked. Also, copying some truetype fonts in to the /usr/share/fonts folder: I was running the File Browser as root, but it still wouldn't let me drag and drop from the network drive. I had to copy the ttf files to a local temp path, and drag and drop from there.

Speaking of the Linkstation network drive, the Windows VM could see it, no problem. Again – I'm using the same username/password for the Windows login. I realise as I write this that I haven't verified that Windows applications can read and write files on the Linux filesystem, but if VirtualBox is anything like VMWare's software, I'm sure there is a way to set up a shared folder and mount it in Windows Explorer.

Ubuntu Again

This post is being written from inside Firefox runing on Ubuntu 9.04.I repartioned the disk into one single EXT4 partition – Windows XP has gone, but the plan is to bring it back via a virtual machine in Virtual Box.

I backed up all my files to our handy network attached storage, a Buffalo LinkStation 250 GB, and I've confirmed that I can access the files from Ubuntu, without any additional configuration. It just scanned the network, it showed up as an icon, and I double-clicked on it and entered my username and password (nothing different about that). It just works. Very cool.

I see the update Manager has just notified me that there are updates. I suppose I should let it have its way with the OS for a bit.

© 2020 More Than Four

Theme by Anders NorenUp ↑